Unable to launch Chrome Desktop App

  1. I’ve created my first Chrome Desktop App from https://developer.chrome.com/apps/first_app
  2. There is instruction to launch the application using parameter line –load-and-launch-app=/path/to/app/ at the bottom section of the above help page.
  3. So I created a Chrome shortcut and added the line “C:Program Files (x86)GoogleChromeApplicationchrome.exe” –load-and-launch-app=/T:/Chrome Projects/Hello World”
  4. But unfortunately, it isn’t working and giving error saying missing manifest though it isn’t Error Screenshot

  5. I can run the app normally if i execute it from chrome browser>Apps section

  6. Also there is no issue if i run the app using ID “C:Program Files (x86)GoogleChromeApplicationchrome.exe” –profile-directory=”Profile 4″ –app-id=geipneggnldmjggcpfhniohfnfnccopo
  7. The App is saved at the folder T:Chrome ProjectsHello World on my system

Any help is much appreciated
Regards,

C# Desktop Application with CEF browser embedded NOT RUNNING on Client’s PC, but runs on development PC’s

I have developed a C# Desktop Application application on VS2013 that has CEF(Chrome Embedded Framework) in it. The Application is developed on .NetFramework 4.5.2 with Target Platform set as x64 (It has to be x64 otherwise CEF doesnt work)

The App runs on the developer PC but when i install it (using a setup) on Clients PC and simply run it by clicking the installed .exe , the mouse pointer loads for a few seconds and then nothing happens. It doesn’t appear in task Manager either. I have tested it by installing another C# Desktop app developed in the same environment and configuration but without CEF , and it is working Fine in all the client’s PC’s.. Is there any problem with the CEF?

Following are the Specs of Developers PC and the Clients PC.

Developers PC : [Application Running]
Windows 10
OS = x64 bit
Visual Studio 2013 with .NETFramework 4.5.2
Visual C++ 2012 Redistributable Package
CEF .dll files included and placed in Debug Folder

Another PC 2 : [Application Running]
Windows 7
OS = x64 bit
Visual Studio 2013 with .NETFramework 4.5.2
Visual C++ 2012 Redistributable Package
CEF .dll files included and placed in Debug Folder

Clients PC 1 [Application NOT Running]
Windows 8.1
OS = x64 bit
Visual C++ 2012 Redistributable Package
CEF .dll files included and placed in Debug Folder

Clients PC 2 [Application NOT Running]
Windows 8.1
OS = x64 bit
Visual C++ 2012 Redistributable Package
CEF .dll files included and placed in Debug Folder

Any help would be highly appreciated. Thanks a lot.